masamune_core 0.5.1+5
masamune_core: ^0.5.1+5

Flutter Android iOS

Library that provides the core part of the Masamune framework. It provides Path map, data management, task management and utility.

0
likes
80 / 110
pub points
55 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1034 out of 1112 API elements (93.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:masamune_core/masamune_core.dart that imports:
  • package:masamune_core/local/local.dart that imports:
  • package:masamune_core/path/path.dart that imports:
  • package:masamune_core/interface/interface.dart that imports:
  • package:masamune_core/dartcore/dartcore.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: A value for optional parameter 'key' isn't ever given.

lib/data/component/joinabledatadocument.dart:423:15

    ╷
423 │       {String key, String prefix, this.document, this.onApply, this.builder})
    │               ^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/data/component/joinabledatadocument.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.9+20.4.9+52.0.2
crypto^2.1.32.1.52.1.5
csv^4.0.34.1.04.1.0
http^0.12.10.12.20.12.2
intl^0.16.10.16.10.16.1
masamune_localize^0.5.00.5.0+10.5.0+1
path_provider^1.6.111.6.241.6.24
shared_preferences^0.5.80.5.12+40.5.12+4
sprintf^4.0.04.1.05.0.0
stack_trace^1.9.31.9.61.10.0-nullsafety.6
url_launcher^5.4.75.7.105.7.10
uuid^2.0.42.2.22.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
connectivity_for_web-0.3.1+40.3.1+4
connectivity_macos-0.1.0+70.1.0+7
connectivity_platform_interface-1.0.61.0.6
convert-2.1.12.1.1
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_device_locale-0.4.00.4.0
http_parser-3.1.43.1.4
js-0.6.3-nullsafety.30.6.3-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+30.0.1+3
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
url_launcher_linux-0.0.1+40.0.1+4
url_launcher_macos-0.0.1+90.0.1+9
url_launcher_platform_interface-1.0.91.0.9
url_launcher_web-0.1.5+10.1.5+1
url_launcher_windows-0.0.1+30.0.1+3
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.9+2` on connectivity does not support the latest published version `2.0.2`

pubspec.yaml:28:17

   ╷
28 │   connectivity: ^0.4.9+2
   │                 ^^^^^^^^
   ╵
The constraint `^4.0.0` on sprintf does not support the latest published version `5.0.0`

pubspec.yaml:24:12

   ╷
24 │   sprintf: ^4.0.0
   │            ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
55%
popularity

Publisher

mathru.net

Library that provides the core part of the Masamune framework. It provides Path map, data management, task management and utility.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

connectivity, crypto, csv, flutter, http, intl, masamune_localize, path_provider, shared_preferences, sprintf, stack_trace, url_launcher, uuid

More

Packages that depend on masamune_core