masamune_localize 0.2.7+3

  • Readme
  • Changelog
  • Example
  • Installing
  • 74

Masamune localization framework #

Library that provides the translation function of Masamune framework. Manage translation data with Google SpreadSheet.

Version Language License: BSD

Getting Started #

Add this to your package's pubspec.yaml file:

dependencies:
  masamune_localize: ^0.1.0

You should then run flutter packages upgrade.

Usage #

import 'package:masamune_localize/masamune_localize.dart';

Example #

Use PageRouteBuilder Widget

Under construction

Test #

run test

flutter test

License #

BSD

[0.2.7] - Update README (2020.07.08) #

  • Add an extension method to get the week string.

[0.2.6] - Update README (2020.06.16) #

  • Fixed a bug that CSV cannot be analyzed by line feed code.

[0.2.5+1] - Update README (2020.06.09) #

  • Formatting.

[0.2.4] - Update README (2020.06.03) #

  • Bug fixes.

[0.2.3] - Update README (2020.05.19) #

  • Web support.

[0.2.0] - Update README (2020.05.15) #

  • Fixed to work standalone instead of relying on the Core package.

[0.1.3] - Update README (2020.04.15) #

  • Change Dependency

[0.1.1] - Update README (2020.04.14) #

  • Change package name.

[0.1.0] - Update README (2020.04.14) #

  • The first release.

example/main.dart

import 'package:masamune_localize/masamune_localize.dart';

void main() async {
  await Localize.initialize("Localization.csv");
  String localized = Localize.get("Hello");
  print(localized);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  masamune_localize: ^0.2.7+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:masamune_localize/masamune_localize.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
48
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:masamune_localize/masamune_localize.dart that imports:
  • package:flutter_device_locale/flutter_device_locale.dart that declares support for platforms: android, ios, web

Package does not support Flutter platform macos

Because:

  • package:masamune_localize/masamune_localize.dart that imports:
  • package:flutter_device_locale/flutter_device_locale.dart that declares support for platforms: android, ios, web

Package does not support Flutter platform windows

Because:

  • package:masamune_localize/masamune_localize.dart that imports:
  • package:flutter_device_locale/flutter_device_locale.dart that declares support for platforms: android, ios, web

Package not compatible with SDK dart

Because:

  • masamune_localize that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
csv ^4.0.3 4.0.3
flutter 0.0.0
flutter_device_locale ^0.4.0 0.4.0
Transitive dependencies
collection 1.14.12 1.14.13
flutter_web_plugins 0.0.0
meta 1.1.8 1.2.1
plugin_platform_interface 1.0.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test
masamune_test ^0.1.0