markup_text 0.2.0
markup_text: ^0.2.0 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Flutter widget to use Markup to easily create formatted Text with colors, style and links.

6
likes
90 / 110
pub points
75 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 26 API elements (7.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/markup_parser.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
url_launcher^5.4.105.7.106.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
flutter_web_plugins-0.0.00.0.0
meta-1.3.0-nullsafety.31.3.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.1
url_launcher_web-0.1.5+32.0.0
url_launcher_windows-0.0.1+32.0.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.4.10` on url_launcher does not support the stable version `6.0.0`, that was published 7 days ago.

When url_launcher is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions url_launcher to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

6
likes
90
pub points
75%
popularity

Flutter widget to use Markup to easily create formatted Text with colors, style and links.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

poqueque@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, url_launcher

More

Packages that depend on markup_text