marketplaceapi 1.0.3
marketplaceapi: ^1.0.3 copied to clipboard

A Marketplace API developed by FromTheInternet

0
likes
40/ 130
pub points
0%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 40 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://fromtheinternet.co.za was unreachable.

Documentation URL doesn't exist.

At the time of the analysis https://fromtheinternet.co.za was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 43 out of 241 API elements (17.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

SDK issues found:

Package is not compatible with the Dart SDK.

Because it is not compatible with any of the supported runtimes: native-aot, native, js.

Package is not compatible with Dart SDK using runtime native-aot. Because:

  • package:marketplaceapi/api.dart that imports:
  • package:http/browser_client.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime native. Because:

  • package:marketplaceapi/api.dart that imports:
  • package:http/browser_client.dart that imports:
  • dart:html

Package is not compatible with Dart SDK using runtime js. Because:

  • package:marketplaceapi/api.dart that imports:
  • package:http/http.dart that imports:
  • package:http/src/streamed_response.dart that imports:
  • package:http/src/base_request.dart that imports:
  • package:http/src/client.dart that imports:
  • package:http/src/io_client.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

lib/api.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/api/baskets_api.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http>=0.11.1 <0.12.00.11.3+170.13.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.11.1 <0.12.0` on http does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
40
pub points
0%
popularity

Publisher

fromtheinternet.co.za

A Marketplace API developed by FromTheInternet

Homepage (missing)

Documentation

Documentation (missing)
API reference

License

MIT (LICENSE)

Dependencies

http

More

Packages that depend on marketplaceapi