markdowneditor 0.0.2 icon indicating copy to clipboard operation
markdowneditor: ^0.0.2 copied to clipboard

A package used to create markdown input field an preview Html markdown.

0
likes
50/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 50 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://slimmusic-7a216.web.app/#/ was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 58 API elements (8.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

ERROR: Undefined name 'FlatButton'.

lib/textview.dart:132:12

    ╷
132 │     return FlatButton.icon(onPressed: (){
    │            ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/textview.dart

WARNING: Missing case clause for 'title'.

lib/package/tfunction.dart:19:5

   ╷
19 │     switch(type){
   │     ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/package/tfunction.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_markdown^0.5.20.5.20.6.13
google_fonts^2.1.02.3.33.0.1
syntax_highlighter^0.1.10.1.10.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.3.2
async-2.10.02.10.0
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
crypto-3.0.23.0.2
ffi-2.0.12.0.1
file-6.1.46.1.4
http-0.13.50.13.5
http_parser-4.0.24.0.2
markdown-3.0.06.0.1
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.31.8.3
path_provider-2.0.112.0.11
path_provider_android-2.0.222.0.22
path_provider_ios-2.0.112.0.11
path_provider_linux-2.1.72.1.7
path_provider_macos-2.0.72.0.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
platform-3.1.03.1.0
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
win32-3.1.34.1.0
xdg_directories-0.2.0+30.2.0+3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.2` on flutter_markdown does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions flutter_markdown to update the constraint.

The constraint `^2.1.0` on google_fonts does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions google_fonts to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.24, Flutter 3.3.10, Dart 2.18.6.

0
likes
50
pub points
0%
popularity

Publisher

unverified uploader

A package used to create markdown input field an preview Html markdown.

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, flutter_markdown, google_fonts, syntax_highlighter

More

Packages that depend on markdowneditor