map_mapper_generator 2.0.0
map_mapper_generator: ^2.0.0 copied to clipboard

Generates code that maps (converts) between instances of business classes to Map<String, dynamic> and back

0
likes
120/ 130
pub points
34%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:map_mapper_generator/map_mapper_generator.dart that imports:
  • package:map_mapper_generator/src/map_map_generator.dart that imports:
  • package:map_mapper_generator/src/field_descriptor.dart that imports:
  • package:squarealfa_generators_common/squarealfa_generators_common.dart that imports:
  • package:squarealfa_generators_common/src/type_checker_extensions.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^2.0.02.8.02.8.0
build^2.0.02.1.12.1.1
decimal^1.0.01.5.02.0.0
map_mapper_annotations^2.0.02.0.02.0.0
source_gen^1.0.01.2.01.2.0
squarealfa_generators_common^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-31.0.031.0.0
args-2.3.02.3.0
async-2.8.22.8.2
boolean_selector-2.1.02.1.0
build_config-1.0.01.0.0
build_resolvers-2.0.52.0.5
build_test-2.1.42.1.4
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
coverage-1.0.31.0.3
crypto-3.0.13.0.1
csslib-0.17.10.17.1
dart_style-2.2.02.2.0
file-6.1.26.1.2
frontend_server_client-2.1.22.1.2
glob-2.0.22.0.2
graphs-2.1.02.1.0
html-0.15.00.15.0
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.31.0.3
js-0.6.30.6.3
json_annotation-4.4.04.4.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
node_preamble-2.0.12.0.1
package_config-2.0.22.0.2
path-1.8.01.8.0
pool-1.5.01.5.0
pub_semver-2.1.02.1.0
pubspec_parse-1.1.01.1.0
rational-1.2.12.0.0
shelf-1.2.01.2.0
shelf_packages_handler-3.0.03.0.0
shelf_static-1.1.01.1.0
shelf_web_socket-1.0.11.0.1
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test-1.19.51.19.5
test_api-0.4.80.4.8
test_core-0.4.90.4.9
typed_data-1.3.01.3.0
vm_service-7.5.07.5.0
watcher-1.0.11.0.1
web_socket_channel-2.1.02.1.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on decimal does not support the stable version `2.0.0`, that was published 1 days ago.

When decimal is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions decimal to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
120
pub points
34%
popularity

Publisher

squarealfa.com

Generates code that maps (converts) between instances of business classes to Map<String, dynamic> and back

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, decimal, map_mapper_annotations, source_gen, squarealfa_generators_common

More

Packages that depend on map_mapper_generator