mailgun 0.1.2 icon indicating copy to clipboard operation
mailgun: ^0.1.2 copied to clipboard

A Flutter package for sending email using Mailgun API

2
likes
80/ 140
pub points
62%
popularity

We analyzed this package 2 days ago, and awarded it 80 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 6 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:mailgun/mailgun.dart that imports:
  • package:mailgun/src/mailgun_mailer.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.00.12.20.13.5
mail^0.1.00.1.00.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.17.01.17.1
http_parser-3.1.44.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

2
likes
80
pub points
62%
popularity

Publisher

unverified uploader

A Flutter package for sending email using Mailgun API

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, http, mail

More

Packages that depend on mailgun