m4d_directive 0.1.16
m4d_directive: ^0.1.16

Dart js
Flutter web

Material Design 4 Dart - Directives

0
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Dec 2, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/MikeMitterer/m4d_directives was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 3 links are insecure.

README.md:7:5

  ╷
7 │ <li><a href="http://m4d_attribute.example.mikemitterer.at">m4d_attribute.example.mikemitterer.at</a></li>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 2 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/m4d_directive/compare/v0.1...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 58 API elements (25.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:m4d_directive/m4d_directive.dart that imports:
  • package:m4d_directive/directive/components/interfaces/stores.dart that imports:
  • package:m4d_core/m4d_core.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 77 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/directive/components/MaterialAttribute.dart:23:1

   ╷
23 │ ┌ /**
24 │ │  * Checks the given condition and adds the given attribute to the components [element].
25 │ │  * Format: [!]<variable> : '<attribute>'
26 │ │  *
27 │ │  * If you put a exclamation mark in front of <variable> the returned value will be inverted
28 │ │  * Variable-Context is "parent". parent is either the next "[ScopeAware]' parent or root-context (MaterialApplication)
29 │ │  *
30 │ │  *    <div class="controls">
31 │ │  *        <div class="mdl-textfield">
32 │ │  *            <input class="mdl-textfield__input" type="text" id="sample-text-attribute" mdl-attribute="!checkAttribute : 'disabled' "/>
33 │ │  *            <label class="mdl-textfield__label" for="sample-text-attribute" mdl-class="checkAttribute : 'enabled'">
34 │ │  *            <span class="enabled">Type something</span>
35 │ │  *            <span class="disabled">I'm Disabled</span>
36 │ │  *        </label>
37 │ │  *        </div>
38 │ │  *        <button class="mdl-button mdl-js-button mdl-ripple-effect" mdl-attribute="!checkAttribute : 'disabled' ">Submit</button>
39 │ │  *    </div>
40 │ │  *
41 │ │  *    @inject
42 │ │  *    class Application extends MaterialApplication {
43 │ │  *          ...
44 │ │  *          final ObservableProperty<bool> checkBorder = new ObservableProperty<bool>(false);
45 │ │  *    }
46 │ │  *
47 │ └  */
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/directive/components/MaterialAttribute.dart

INFO: Unnecessary new keyword.

lib/directive/components/MaterialAttribute.dart:50:28

   ╷
50 │     final Logger _logger = new Logger('mdldirective.MaterialAttribute');
   │                            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/directive/components/MaterialAttribute.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_log_handler^1.0.01.1.61.1.6
intl^0.15.00.15.80.16.1
logging>=0.11.3 <1.0.00.11.40.11.4
m4d_components>=0.1.0 <1.0.00.1.310.1.31
m4d_core>=0.2.0 <1.0.00.2.210.2.21
m4d_flux>=0.1.0 <1.0.00.1.00.1.0
meta^1.1.01.2.41.2.4
path^1.4.01.7.01.7.0
platform_detect^1.3.01.4.01.4.0
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.014.0.0
analyzer-0.39.170.41.1
ansicolor-1.1.11.1.1
args-1.6.01.6.0
async-2.4.22.4.2
build_cli_annotations-1.2.01.2.0
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.10
file-5.2.15.2.1
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
intl_translation-0.17.10+10.17.10+1
js-0.6.20.6.2
l10n-2.0.192.0.19
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
optional-3.1.05.0.0+1
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
where-4.4.08.0.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.0` on intl does not support the latest published version `0.16.1`

pubspec.yaml:11:9

   ╷
11 │   intl: ^0.15.0
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs