m4d_animation 0.1.4 icon indicating copy to clipboard operation
m4d_animation: ^0.1.4 copied to clipboard

Material Design 4 Dart - Animation

0
likes
50/ 130
pub points
0%
popularity

We analyzed this package 34 hours ago, and awarded it 50 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 47 API elements (40.4 %) have documentation comments.
icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

SDK issues found:

Package is not compatible with the Dart SDK.

Package is not compatible with the Dart SDK. Because:

  • package:m4d_animation/m4d_animation.dart that imports:
  • dart:html_common

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:m4d_animation/m4d_animation.dart that imports:
  • dart:html_common
Package not compatible with platform iOS

Because:

  • package:m4d_animation/m4d_animation.dart that imports:
  • dart:html_common
Package not compatible with platform Windows

Because:

  • package:m4d_animation/m4d_animation.dart that imports:
  • dart:html_common
Package not compatible with platform Linux

Because:

  • package:m4d_animation/m4d_animation.dart that imports:
  • dart:html_common
Package not compatible with platform macOS

Because:

  • package:m4d_animation/m4d_animation.dart that imports:
  • dart:html_common
Package not compatible with platform Web

Because:

  • package:m4d_animation/m4d_animation.dart that imports:
  • dart:html_common
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

INFO: Name source files using `lowercase_with_underscores`.

To reproduce make sure you are using the lints_core and run dart analyze lib/animation/StockAnimation.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/animation/StockAnimation.dart:45:33

   ╷
45 │     static final StockAnimation NoOp =
   │                                 ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/animation/StockAnimation.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_log_handler^1.0.01.1.61.1.6
logging>=0.11.3 <1.0.00.11.41.0.2
m4d_core>=0.2.0 <1.0.00.2.210.2.21
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
analyzer-0.33.3+24.1.0
ansicolor-1.1.12.0.1
args-1.6.02.3.1
async-2.9.02.9.0
build_cli_annotations-1.2.02.0.0
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.1
crypto-2.1.53.0.2
csslib-0.17.10.17.1
dart_style-1.2.02.2.3
file-5.2.16.1.2
front_end-0.1.6+50.1.29
glob-1.2.02.0.2
html-0.15.00.15.0
intl-0.15.80.17.0
intl_translation-0.17.40.17.10+1
js-0.6.40.6.4
kernel-0.3.6+50.3.29
l10n-2.0.192.0.19
meta-1.6.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
optional-3.1.06.1.0+1
package_config-1.9.32.0.2
path-1.8.11.8.1
pedantic-1.11.11.11.1
petitparser-2.4.05.0.0
platform_detect-1.4.22.0.3
plugin-0.2.0+30.2.0+3
pub_semver-2.1.12.1.1
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
watcher-0.9.7+151.0.1
where-4.4.08.0.0
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.11.3 <1.0.0` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Dart 2.17.0.

0
likes
50
pub points
0%
popularity

Publisher

unverified uploader

Material Design 4 Dart - Animation

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

console_log_handler, logging, m4d_core, validate

More

Packages that depend on m4d_animation