log_4_dart_2 0.4.0
log_4_dart_2: ^0.4.0 copied to clipboard

A dart package for logging, with multiple and configurable appenders.

3
likes
90/ 130
pub points
45%
popularity

We analyzed this package 27 hours ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 122 out of 171 API elements (71.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:log_4_dart_2/log_4_dart_2.dart that imports:
  • package:log_4_dart_2/src/appender/EmailAppender.dart that imports:
  • package:mailer/mailer.dart that imports:
  • package:mailer/src/smtp/mail_sender.dart that imports:
  • package:mailer/src/smtp/smtp_client.dart that imports:
  • package:mailer/src/smtp/internal_representation/internal_representation.dart that imports:
  • package:mailer/src/entities/message.dart that imports:
  • package:mailer/src/entities/attachment.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
basic_utils^2.4.72.7.13.9.1
intl^0.16.00.16.10.17.0
mailer^3.0.43.3.05.0.2
mysql1^0.17.10.17.10.19.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
http-0.12.20.13.4
http_parser-3.1.44.0.0
json_annotation-3.1.14.4.0
logging-0.11.41.0.2
meta-1.7.01.7.0
mime-0.9.71.0.1
path-1.8.01.8.0
pointycastle-2.0.13.4.0
pool-1.5.01.5.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.4.7` on basic_utils does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions basic_utils to update the constraint.

The constraint `^0.16.0` on intl does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.0.

3
likes
90
pub points
45%
popularity

A dart package for logging, with multiple and configurable appenders.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

basic_utils, intl, mailer, mysql1

More

Packages that depend on log_4_dart_2