lodash_flutter 0.0.3 copy "lodash_flutter: ^0.0.3" to clipboard
lodash_flutter: ^0.0.3 copied to clipboard

Utility library - lodash is a dart utility library inspired by javascript lodash library.

9
likes
110/ 140
pub points
69%
popularity

We analyzed this package 9 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

38 out of 51 API elements (74.5 %) have documentation comments.

Some symbols that are missing documentation: lodash_flutter, lodash_flutter.LodashFlutter, lodash_flutter.LodashFlutter.LodashFlutter, lodash_flutter.LodashFlutter.getRandomString, lodash_flutter.LodashFlutter.platformVersion.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:lodash_flutter/lodash_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:lodash_flutter/lodash_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:lodash_flutter/lodash_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:lodash_flutter/lodash_flutter.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: An uninitialized variable should have an explicit type annotation.

lib/lodash_flutter.dart:168:11

    ╷
168 │     final index;
    │           ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/lodash_flutter.dart

INFO: An uninitialized variable should have an explicit type annotation.

lib/lodash_flutter.dart:193:11

    ╷
193 │     final index;
    │           ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/lodash_flutter.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

9
likes
110
pub points
69%
popularity

Publisher

unverified uploader

Utility library - lodash is a dart utility library inspired by javascript lodash library.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on lodash_flutter