localization 0.1.0
localization: ^0.1.0 copied to clipboard

Package to simplify the package translation.

12
likes
80 / 110
pub points
84 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 14 API elements (7.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:localization/localization.dart that imports:
  • package:localization/src/localization_widget.dart that imports:
  • package:localization/src/extension.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

12
likes
80
pub points
84%
popularity

Package to simplify the package translation.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

davidsdearaujo@gmail.com

License

LICENSE

Dependencies

flutter

More

Packages that depend on localization