loading_overlay_pro 2.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new61

loading_overlay_pro Pub #

A simple widget wrapper set of loading animations for Flutter projects.

Use animation from https://github.com/cytryn/loading-animations

Getting Started #

Then import the file to your project:

import 'package:loading_overlay_pro/loading_overlay_pro.dart'

Then add the following code:

 LoadingOverlayPro({
    Key key,
    @required this.isLoading,
    @required this.child,
    this.colorBackground = Colors.black54,
    this.progressIndicator = const LoadingBouncingLine.circle(),
  });

Or customize it even more!

LoadingBouncingLine.circle(
  borderColor: Colors.cyan,
  borderSize: 3.0,
  size: 120.0,
  backgroundColor: Colors.cyanAccent,
  duration: Duration(milliseconds: 500),
);

For more customization, please look inside the loading animation files.

Note: all the animations come ready to go just by calling LoadingBouncingLine.square(), for example.

Many basic animations contain .circle() and .square() variations by default.

Example #

[2.0.0] - Updating package details. #

Fix: #

Fixing on pubspec.yaml Added full path to example images

[1.0.0+1] - First release. #

First version released with 4 animations:

List of animation changes:

  • LoadingFlipCircle() -> LoadingFlipping.circle() or .square()
  • LoadingRotatingSquare() -> LoadingRotating.square()
  • LoadingFlipBox() -> LoadingDoubleFlipping.circle() or .square()
  • LoadingBouncingGrid() -> LoadingBouncingGrid.circle() or .square()

default: LoadingBouncingGrid.circle()

example/lib/main.dart

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:loading_overlay_pro/loading_overlay_pro.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) => MaterialApp(
        debugShowCheckedModeBanner: false,
        theme: ThemeData(
          primarySwatch: Colors.blue,
        ),
        home: DemoPage(),
      );
}

class DemoPage extends StatefulWidget {
  @override
  _DemoPageState createState() => _DemoPageState();
}

class _DemoPageState extends State<DemoPage> {
  bool _isLoading = false;

  void _submit() {
    setState(() {
      _isLoading = true;
    });

    Future.delayed(Duration(seconds: 2), () {
      setState(() {
        _isLoading = false;
      });
    });
  }

  @override
  Widget build(BuildContext context) => Scaffold(
        appBar: AppBar(
          title: Text('Loading Overlay Pro'),
          backgroundColor: Colors.blue,
        ),
        body: LoadingOverlayPro(
          child: Center(
            child: RaisedButton(
              onPressed: _submit,
              child: Text('Show Loading'),
            ),
          ),
          isLoading: _isLoading,
          progressIndicator: LoadingBouncingLine.circle(
            backgroundColor: Colors.blue,
            size: 150.0,
            duration: Duration(seconds: 2),
            borderColor: Colors.blue,
          ),
        ),
      );
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  loading_overlay_pro: ^2.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:loading_overlay_pro/loading_overlay_pro.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jul 6, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [loading_overlay_pro] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
cupertino_icons ^0.1.3 0.1.3
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test