live_barcode_scanner 0.0.1+1

live_barcode_scanner #

Plugin to include camera widget in your app that will also scan barcodes using firebase_ml_vision.

Installation #

Add live_barcode_scanner into your pubspec.yaml file.

Then follow platform specific usage and installation for both camera and firebase_ml_vision plugins.

Usage #

On example usage check out the example app.

0.0.1+1 #

  • Fixed pubspec.yaml

0.0.1 #

  • Initial Release

example/README.md

example #

Example for live_barcode_scanner plugin.

Usage #

This example is currently set up only for Android. To run this example you must first create your Firebase project and add google-services.json into example/android/app folder.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  live_barcode_scanner: ^0.0.1+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:live_barcode_scanner/live_barcode_scanner.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (camera, firebase_ml_vision).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
camera ^0.3.0+3 0.3.0+3 0.5.4+2
firebase_ml_vision ^0.4.0+1 0.4.0+1 0.9.2+1
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test