live_activities 1.9.1+1 copy "live_activities: ^1.9.1+1" to clipboard
live_activities: ^1.9.1+1 copied to clipboard

A Flutter plugin to use iOS 16.1+ Live Activities & iPhone 14 Pro Dynamic Island features

312
likes
140/ 160
pub points
93%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

20 out of 113 API elements (17.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: activity_update, activity_update.ActiveActivityUpdate, activity_update.ActiveActivityUpdate.ActiveActivityUpdate, activity_update.ActiveActivityUpdate.activityToken, activity_update.ActiveActivityUpdate.map.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:live_activities/live_activities.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:live_activities/live_activities.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:live_activities/live_activities.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:live_activities/live_activities.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'dart:typed_data' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/services.dart'.

lib/models/live_activity_image.dart:1:8

  ╷
1 │ import 'dart:typed_data';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/live_activity_image.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
app_group_directory ^2.0.0 2.0.0 2.0.0
flutter flutter 0.0.0 0.0.0
flutter_image_compress ^2.0.4 2.3.0 2.3.0
flutter_native_image ^0.0.6+1 0.0.6+1 0.0.6+1
path_provider ^2.1.1 2.1.3 2.1.3
plugin_platform_interface ^2.1.6 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
cross_file - 0.3.4+1 0.3.4+1
ffi - 2.1.2 2.1.2
flutter_image_compress_common - 1.0.5 1.0.5
flutter_image_compress_macos - 1.0.2 1.0.2
flutter_image_compress_ohos - 0.0.3 0.0.3
flutter_image_compress_platform_interface - 1.0.5 1.0.5
flutter_image_compress_web - 0.1.4+1 0.1.4+1
flutter_web_plugins - 0.0.0 0.0.0
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.