lit_firebase_auth 0.3.0

Flutter Android iOS web

Pre-lit Firebase Authentication. Drop in and add Firebase Auth in just minutes.

74
likes
90 / 110
pub points
87 %
popularity

We analyzed this package on Oct 24, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 83 out of 285 API elements (29.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:lit_firebase_auth/lit_firebase_auth.dart that imports:
  • package:lit_firebase_auth/src/presentation/widgets/sign_in_text_fields.dart that imports:
  • package:lit_firebase_auth/src/application/auth/sign_in_handler/sign_in_handler_state_notifier.dart that imports:
  • package:lit_firebase_auth/src/domain/auth/i_auth_facade.dart that imports:
  • package:lit_firebase_auth/src/domain/auth/user.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web
Package does not support Flutter platform Linux

Because:

  • package:lit_firebase_auth/lit_firebase_auth.dart that imports:
  • package:lit_firebase_auth/src/presentation/widgets/sign_in_text_fields.dart that imports:
  • package:lit_firebase_auth/src/application/auth/sign_in_handler/sign_in_handler_state_notifier.dart that imports:
  • package:lit_firebase_auth/src/domain/auth/i_auth_facade.dart that imports:
  • package:lit_firebase_auth/src/domain/auth/user.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web
Package does not support Flutter platform macOS

Because:

  • package:lit_firebase_auth/lit_firebase_auth.dart that imports:
  • package:lit_firebase_auth/src/presentation/lit_auth_init.dart that imports:
  • package:lit_firebase_auth/src/infrastructure/firebase_auth_facade.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The declaration '_$identity' isn't referenced.

lib/src/domain/auth/auth_failure.freezed.dart:10:3

   ╷
10 │ T _$identity<T>(T value) => value;
   │   ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/domain/auth/auth_failure.freezed.dart

INFO: 'autovalidate' is deprecated and shouldn't be used. Use autoValidateMode parameter which provides more specific behavior related to auto validation. This feature was deprecated after v1.19.0..

lib/src/presentation/widgets/sign_in_form.dart:24:7

   ╷
24 │       autovalidate: showErrorMessages,
   │       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/presentation/widgets/sign_in_form.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dartz^0.9.10.9.20.9.2
firebase_auth^0.18.0+10.18.1+20.18.1+2
firebase_auth_oauth^0.2.10.2.10.2.1
firebase_core^0.5.00.5.0+10.5.0+1
flushbar^1.10.41.10.41.10.4
flutterflutter0.0.00.0.0
flutter_state_notifier^0.6.10.6.10.6.1
freezed_annotation^0.11.0+10.11.0+10.12.0
google_sign_in^4.5.14.5.54.5.5
meta^1.1.81.3.0-nullsafety.31.3.0-nullsafety.5
provider^4.2.04.3.2+24.3.2+2
state_notifier^0.6.00.6.00.6.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
charcode-1.1.31.2.0-nullsafety.1
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
firebase-7.3.27.3.2
firebase_auth_oauth_platform_interface-0.2.10.2.1
firebase_auth_oauth_web-0.2.10.2.1
firebase_auth_platform_interface-2.1.12.1.1
firebase_auth_web-0.3.1+10.3.1+1
firebase_core_platform_interface-2.0.02.0.0
firebase_core_web-0.2.00.2.0
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-1.1.21.1.2
google_sign_in_web-0.9.20.9.2
http-0.12.20.12.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.03.1.0
matcher-0.12.90.12.10-nullsafety.2
nested-0.0.40.0.4
path-1.7.01.8.0-nullsafety.2
pedantic-1.9.21.9.2
plugin_platform_interface-1.0.31.0.3
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.8.0-nullsafety.3
stack_trace-1.9.51.10.0-nullsafety.5
string_scanner-1.0.51.1.0-nullsafety.2
term_glyph-1.1.01.2.0-nullsafety.2
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.0+1` on freezed_annotation does not support the latest published version `0.12.0`

pubspec.yaml:21:23

   ╷
21 │   freezed_annotation: ^0.11.0+1
   │                       ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs