linter 0.1.125
linter: ^0.1.125

Dart

The implementation of the lint rules supported by the analyzer framework. This package is not intended to be used directly.

21
likes
80 / 110
pub points
86 %
popularity

We analyzed this package on Nov 21, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/readme.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.40.40.40.60.41.0
args>=1.4.0 <2.0.01.6.01.6.0
charcode^1.0.01.1.31.1.3
glob^1.0.31.2.01.2.0
http^0.12.00.12.20.12.2
meta^1.0.21.2.41.2.4
path^1.2.01.7.01.7.0
source_span^1.0.21.7.01.7.0
yaml^2.1.22.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.013.0.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
file-5.2.15.2.1
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.20.6.2
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.40.4` on analyzer does not support the latest published version `0.41.0`

pubspec.yaml:15:13

   ╷
15 │   analyzer: ^0.40.4
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

21
likes
80
pub points
86%
popularity

The implementation of the lint rules supported by the analyzer framework. This package is not intended to be used directly.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploaders

pquitslund@google.com
brianwilkerson@google.com
kevmoo@google.com
devoncarew@google.com

License

BSD (LICENSE)

Dependencies

analyzer, args, charcode, glob, http, meta, path, source_span, yaml

More

Packages that depend on linter