likk_picker 1.1.5+1 copy "likk_picker: ^1.1.5+1" to clipboard
likk_picker: ^1.1.5+1 copied to clipboard

Camera and Gallery picker asset from Photo Manager. Custom view from Facebook Messenger. (Image Picker, Camera, Gallery Reader)

58
likes
70/ 140
pub points
75%
popularity

We analyzed this package 4 days ago, and awarded it 70 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

249 out of 523 API elements (47.6 %) have documentation comments.

Some symbols that are missing documentation: custom_icons.CustomIcons, custom_icons.CustomIcons.camera, custom_icons.CustomIcons.cameraRotate, custom_icons.CustomIcons.close, custom_icons.CustomIcons.flashoff.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:likk_picker/likk_picker.dart that imports:
  • package:likk_picker/src/playground/src/widgets/playground_textfield.dart that imports:
  • package:likk_picker/src/playground/src/controller/playground_controller.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:likk_picker/likk_picker.dart that imports:
  • package:likk_picker/src/playground/src/widgets/playground_textfield.dart that imports:
  • package:likk_picker/src/playground/src/controller/playground_controller.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:likk_picker/likk_picker.dart that imports:
  • package:likk_picker/src/playground/src/widgets/playground_overlay.dart that imports:
  • package:likk_picker/src/playground/src/widgets/playground_capture_button.dart that imports:
  • package:likk_picker/src/camera/src/widgets/ui_handler.dart that imports:
  • package:camera/camera.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:likk_picker/likk_picker.dart that imports:
  • package:likk_picker/src/playground/src/widgets/playground_textfield.dart that imports:
  • package:likk_picker/src/playground/src/controller/playground_controller.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 80 issues. Showing the first 2:

ERROR: The method 'disallowGlow' isn't defined for the type 'OverscrollIndicatorNotification'.

lib/src/animations/src/scroll_listener.dart:153:20

    ╷
153 │       notification.disallowGlow();
    │                    ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/animations/src/scroll_listener.dart

ERROR: The method 'setEnabledSystemUIOverlays' isn't defined for the type 'SystemChrome'.

lib/src/camera/src/camera_view.dart:157:18

    ╷
157 │     SystemChrome.setEnabledSystemUIOverlays([]);
    │                  ^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/camera/src/camera_view.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
camera ^0.9.1 0.9.8+1 0.11.0
flutter flutter 0.0.0 0.0.0
image_cropper ^1.4.1 1.5.1 6.0.0
path ^1.8.0 1.9.0 1.9.0
photo_manager ^1.3.1 1.3.10 3.1.1
uuid ^3.0.4 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
camera_android - 0.9.8+3 0.10.9+2
camera_avfoundation - 0.9.16 0.9.16
camera_platform_interface - 2.7.4 2.7.4
camera_web - 0.2.1+6 0.3.3
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_web_plugins - 0.0.0 0.0.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.9.1` on camera does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

The constraint `^1.4.1` on image_cropper does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions image_cropper to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

58
likes
70
pub points
75%
popularity

Publisher

verified publishertranhuongk.xyz

Camera and Gallery picker asset from Photo Manager. Custom view from Facebook Messenger. (Image Picker, Camera, Gallery Reader)

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

camera, flutter, image_cropper, path, photo_manager, uuid

More

Packages that depend on likk_picker