lightning_api 0.11.11 copy "lightning_api: ^0.11.11" to clipboard
lightning_api: ^0.11.11 copied to clipboard

Provices a Stream interface to the LeoFinance Lightning HTTP API.

0
likes
110/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

51 out of 334 API elements (15.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: lightning_api, lightning_api.Account, lightning_api.Account.Account, lightning_api.Account.balance, lightning_api.Account.canVote.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.3 2.0.5 2.0.5
hive_api ^0.4.0 0.4.6 0.4.6
http ^0.13.3 0.13.6 1.2.1
intl ^0.17.0 0.17.0 0.19.0
json_annotation ^4.5.0 4.8.1 4.8.1
logging ^1.0.2 1.2.0 1.2.0
rxdart ^0.27.3 0.27.7 0.27.7
scot_api ^0.4.1 0.4.3 0.4.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

0
likes
110
pub points
0%
popularity

Publisher

verified publisherleofinance.io

Provices a Stream interface to the LeoFinance Lightning HTTP API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

equatable, hive_api, http, intl, json_annotation, logging, rxdart, scot_api

More

Packages that depend on lightning_api