latlong 0.6.1
latlong: ^0.6.1 copied to clipboard

Lightweight library for common latitude and longitude calculation

94
likes
70/ 130
pub points
96%
popularity

We analyzed this package 21 hours ago, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:6:4

  ╷
6 │ <p><a href="http://hawkesy.blogspot.co.at/2010/05/catmull-rom-spline-curve-implementation.html">Catmull-Rom algorithm</a> is used for smoothing out the path.</p>
  │    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 9 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/dart-latlong/compare/v0.6...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 40 out of 99 API elements (40.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

lib/latlong.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/latlong/Circle.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
console_log_handler>=1.1.0 <2.0.01.1.61.1.6
intl>=0.15.0 <1.0.00.17.00.17.0
logging>=0.11.3 <1.0.00.11.41.0.2
validate^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.12.0.1
clock-1.1.01.1.0
path-1.8.01.8.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.11.3 <1.0.0` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.0.

94
likes
70
pub points
96%
popularity

Lightweight library for common latitude and longitude calculation

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

console_log_handler, intl, logging, validate

More

Packages that depend on latlong