lambert 2.0.0 copy "lambert: ^2.0.0" to clipboard
lambert: ^2.0.0 copied to clipboard

Lambert coordinates convertion package from Lambert system to WGS84 system.

0
likes
130/ 140
pub points
14%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

10 out of 10 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

INFO: The variable name 'lat_iso' isn't a lowerCamelCase identifier.

lib/src/algo.dart:13:39

   ╷
13 │ double latitudeFromLatitudeISO(double lat_iso, double e, double eps) {
   │                                       ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/algo.dart

INFO: The variable name 'phi_i' isn't a lowerCamelCase identifier.

lib/src/algo.dart:15:10

   ╷
15 │   double phi_i = 2 *
   │          ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/algo.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

0
likes
130
pub points
14%
popularity

Publisher

verified publisheryageek.net

Lambert coordinates convertion package from Lambert system to WGS84 system.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on lambert