lambert 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 45

MIT License

lambert-dart #

lambert-dart is a crate helping to convert Lambert coordinates to WGS84.

Usage #

import 'package:lambert/lambert.dart' as lambert;

main() {
  lambert.Point point = new lambert.Point(668832.5384,6950138.7285,0.0);
  lambert.Point expected = new lambert.Point(2.56865, 49.64961, 0.0);

  lambert.Point result = point.convert(lambert.Zone.L93).degree();

  print("WGS84 Lat: ${result.y} Lon:${result.x}");
}

Changelog #

1.0.0 #

  • Dart 2 compatibility

0.0.1 #

  • Basic version

example/lambert_example.dart

// Copyright (c) 2016, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library lambert.example;

import 'package:lambert/lambert.dart' as lambert;

main() {
  lambert.Point point = new lambert.Point(668832.5384, 6950138.7285, 0.0);
  lambert.Point expected = new lambert.Point(2.56865, 49.64961, 0.0);

  lambert.Point result = point.convert(lambert.Zone.L93).degree();

  print("Result: ${result.y} ${result.x}");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  lambert: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:lambert/lambert.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
78
Overall:
Weighted score of the above. [more]
45
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Health suggestions

Fix lib/src/lambert_algo.dart. (-1.99 points)

Analysis of lib/src/lambert_algo.dart reported 4 hints:

line 6 col 31: Use lowercase_with_underscores when specifying a library prefix.

line 56 col 10: Unnecessary new keyword.

line 67 col 20: Unnecessary new keyword.

line 113 col 10: Unnecessary new keyword.

Fix lib/src/lambert_point.dart. (-1.49 points)

Analysis of lib/src/lambert_point.dart reported 3 hints:

line 3 col 31: Use lowercase_with_underscores when specifying a library prefix.

line 4 col 32: Use lowercase_with_underscores when specifying a library prefix.

line 47 col 12: Unnecessary new keyword.

Format lib/lambert.dart.

Run dartfmt to format lib/lambert.dart.

Format lib/src/lambert_zone.dart.

Run dartfmt to format lib/src/lambert_zone.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Update README.md. (-2 points)

1 image link is insecure (e.g. http://img.shields.io/badge/license-MIT-blue.svg?style=flat), use https URLs instead.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
build_runner ^1.0.0
build_test ^0.10.2
build_web_compilers ^0.4.0
test ^1.0.0