lakos 1.1.1
lakos: ^1.1.1 copied to clipboard

Visualize Dart library dependencies in Graphviz dot. Detect dependency cycles.

22
likes
90/ 130
pub points
42%
popularity

We analyzed this package on Nov 8, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 88 out of 94 API elements (93.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:lakos/lakos.dart that imports:
  • package:lakos/src/metrics.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.02.3.0
directed_graph^0.2.00.2.30.3.5
glob^1.2.01.2.02.0.2
path^1.7.01.8.01.8.0
string_scanner^1.0.51.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
file-5.2.16.1.2
graphs-0.2.02.1.0
intl-0.17.00.17.0
js-0.6.30.6.3
lazy_evaluation-0.0.6+31.1.0
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.6.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.2.0` on directed_graph does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions directed_graph to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

22
likes
90
pub points
42%
popularity

Publisher

olegalexander.com

Visualize Dart library dependencies in Graphviz dot. Detect dependency cycles.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, directed_graph, glob, path, string_scanner

More

Packages that depend on lakos