ky_tool_plugin 1.0.3
ky_tool_plugin: ^1.0.3 copied to clipboard

A new Flutter plugin.

0
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 43 out of 326 API elements (13.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:ky_tool_plugin/ky_tool_plugin.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

lib/config/ky_chinese_localization.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/config/ky_default_utils.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.0.03.1.0+13.1.0+1
connectivity^3.0.33.0.63.0.6
date_format^2.0.22.0.42.0.4
dio^4.0.04.0.44.0.4
flustars^2.0.12.0.12.0.1
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
image_gallery_saver^1.6.91.7.11.7.1
keyboard_actions^3.4.03.4.43.4.4
local_auth^1.1.51.1.81.1.8
oktoast^3.0.03.1.43.1.5
package_info^2.0.02.0.22.0.2
permission_handler^6.1.16.1.38.3.0
photo_view^0.11.10.11.10.13.0
system_settings^2.0.02.0.02.0.0
url_launcher^6.0.36.0.156.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
common_utils-2.0.22.0.2
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
convert-3.0.13.0.1
crypto-3.0.13.0.1
decimal-1.5.01.5.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.1.33.1.3
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.7.01.7.0
octo_image-1.0.0+11.0.0+1
path-1.8.01.8.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
permission_handler_platform_interface-3.7.03.7.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
rational-1.2.11.2.1
rxdart-0.27.30.27.3
shared_preferences-2.0.92.0.9
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sp_util-2.0.32.0.3
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.1.1` on permission_handler does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

The constraint `^0.11.1` on photo_view does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.