kplayer_with_just_audio 0.3.3 copy "kplayer_with_just_audio: ^0.3.3" to clipboard
kplayer_with_just_audio: ^0.3.3 copied to clipboard

kplayer with just_audio.

0
likes
100/ 140
pub points
5%
popularity

We analyzed this package 29 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is:issue is:open label:"kplayer" was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

11 out of 59 API elements (18.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: kplayer_with_just_audio, kplayer_with_just_audio.JustAudioBytesSource, kplayer_with_just_audio.JustAudioBytesSource.JustAudioBytesSource, kplayer_with_just_audio.JustAudioBytesSource.duration, kplayer_with_just_audio.JustAudioBytesSource.sequence.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:kplayer_with_just_audio/kplayer_with_just_audio.dart that imports:
  • package:just_audio/just_audio.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:kplayer_with_just_audio/kplayer_with_just_audio.dart that imports:
  • package:just_audio/just_audio.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Web`.

Because:

  • package:kplayer_with_just_audio/kplayer_with_just_audio.dart that imports:
  • package:just_audio/just_audio.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
just_audio ^0.9.28 0.9.37 0.9.37
kplayer_platform_interface ^0.3.3 0.3.3 0.4.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
audio_session - 0.1.19 0.1.19
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
just_audio_platform_interface - 4.2.2 4.2.2
just_audio_web - 0.4.9 0.4.9
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.3` on kplayer_platform_interface does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions kplayer_platform_interface to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.