kosher_dart 2.0.16 copy "kosher_dart: ^2.0.16" to clipboard
kosher_dart: ^2.0.16 copied to clipboard

This Plugin for a specialized calendar that can calculate different astronomical times for Jewish zmanim or religious times for prayers and other Jewish religious duties.

21
likes
110/ 140
pub points
76%
popularity

We analyzed this package 17 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: LGPL-2.1.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

510 out of 547 API elements (93.2 %) have documentation comments.

Some symbols that are missing documentation: kosher_dart, kosher_dart.ComplexZmanimCalendar.clone, kosher_dart.ComplexZmanimCalendar.getMidday, kosher_dart.ComplexZmanimCalendar.getTaanisExitTime, kosher_dart.ComplexZmanimCalendar.getTaanisStartTime.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 92 issues. Showing the first 2:

WARNING: Doc directive 'link' is unknown.

lib/src/astronomical_calendar.dart:105:9

    ╷
105 │   /// {@link AstronomicalCalculator#getElevationAdjustment(double) elevation adjusted} sunrise time. The zenith used
    │         ^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/astronomical_calendar.dart

WARNING: Doc directive 'link' is unknown.

lib/src/astronomical_calendar.dart:107:9

    ╷
107 │   /// {@link AstronomicalCalculator#getElevationAdjustment(double)}. This is adjusted by the
    │         ^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/astronomical_calendar.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
intl ^0.18.1 0.18.1 0.19.0
pedantic ^1.11.0 1.11.1 1.11.1
vector_math ^2.1.4 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.1` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

21
likes
110
pub points
76%
popularity

Publisher

verified publisherbeninsapps.com

This Plugin for a specialized calendar that can calculate different astronomical times for Jewish zmanim or religious times for prayers and other Jewish religious duties.

Repository (GitHub)
View/report issues

Documentation

API reference

License

LGPL-2.1 (LICENSE)

Dependencies

intl, pedantic, vector_math

More

Packages that depend on kosher_dart