knuffimap 0.0.2

Flutter Android iOS web

An abstraction over `package:firebase_database`.

0
likes
80 / 110
pub points
43 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 57 out of 86 API elements (66.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.01.14.131.14.13
firebase_database^3.0.53.1.64.0.0
flutterflutter0.0.00.0.0
meta^1.1.81.1.81.2.3
rxdart^0.23.10.23.10.24.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
firebase-7.3.07.3.0
firebase_core-0.4.50.5.0
firebase_core_platform_interface-1.0.42.0.0
firebase_core_web-0.1.1+20.2.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.12.2
http_parser-3.1.43.1.4
js-0.6.20.6.2
matcher-0.12.90.12.9
path-1.7.01.7.0
pedantic-1.9.01.9.2
plugin_platform_interface-1.0.21.0.2
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.5` on firebase_database does not support the latest published version `4.0.0`

pubspec.yaml:12:22

   ╷
12 │   firebase_database: ^3.0.5
   │                      ^^^^^^
   ╵
The constraint `^0.23.1` on rxdart does not support the latest published version `0.24.1`

pubspec.yaml:14:11

   ╷
14 │   rxdart: ^0.23.1
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
43%
popularity

An abstraction over `package:firebase_database`.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

fmutzel@gmail.com

License

MIT (LICENSE)

Dependencies

collection, firebase_database, flutter, meta, rxdart

More

Packages that depend on knuffimap