knuffimap 0.0.2

knuffimap #

An abstraction over package:firebase_database. It provides three things:

  1. An adapter to turn Firebase references into a Stream<KnuffiMap<T>>. This automates mapping JSON to objects and works nicely with deserialization via package:built_value. See knuffimap.
  2. An in-memory database implementation for tests. See in_memory.
  3. A collection of Widgets to rebuild whenever dependent Streams change. This is similar to StreamBuilder, but simpler, more limited and allows multiple dependent streams. See stream_widget.dart.

[0.0.2] - January 11, 2020

  • Relax version constraints on package:collection.

[0.0.1] - January 11, 2020

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  knuffimap: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:knuffimap/knuffimap.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
68
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Maintenance suggestions

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and knuffimap.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
collection ^1.14.0 1.14.11 1.14.12
firebase_database ^3.0.5 3.1.1
flutter 0.0.0
meta ^1.1.8 1.1.8
rxdart ^0.23.1 0.23.1
Transitive dependencies
async 2.4.0
charcode 1.1.3
firebase 7.2.1
firebase_core 0.4.4
firebase_core_platform_interface 1.0.2
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.0+4
http_parser 3.1.3
js 0.6.1+1
matcher 0.12.6
path 1.6.4
pedantic 1.9.0
quiver 2.1.2+1
sky_engine 0.0.99
source_span 1.6.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8