knt_ad_monetized 1.0.0 copy "knt_ad_monetized: ^1.0.0" to clipboard
knt_ad_monetized: ^1.0.0 copied to clipboard

PlatformiOS

Helper blocs for handling common admob flow.

0
likes
110/ 140
pub points
26%
popularity

We analyzed this package 33 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/appixi/knt_ad_monetized was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: knt_ad_monetized,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

514 out of 683 API elements (75.3 %) have documentation comments.

Some symbols that are missing documentation: knt_ad_monetized, knt_ad_monetized.AdExtension, knt_ad_monetized.AdExtension.loadAppOpenAd, knt_ad_monetized.AdExtension.loadBannerAd, knt_ad_monetized.AdExtension.loadInterstitialAd.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:knt_ad_monetized/knt_ad_monetized.dart that imports:
  • package:knt_ad_monetized/src/widget/widgets.dart that imports:
  • package:knt_ad_monetized/src/widget/knt_native_ad.dart that imports:
  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:knt_ad_monetized/knt_ad_monetized.dart that imports:
  • package:knt_ad_monetized/src/widget/widgets.dart that imports:
  • package:knt_ad_monetized/src/widget/knt_native_ad.dart that imports:
  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Linux`.

Because:

  • package:knt_ad_monetized/knt_ad_monetized.dart that imports:
  • package:knt_ad_monetized/src/widget/widgets.dart that imports:
  • package:knt_ad_monetized/src/widget/knt_interstitial_ad.dart that imports:
  • package:knt_ad_monetized/src/bloc/ad_without_view_bloc.dart that imports:
  • package:knt_ad_monetized/src/service/admob_service.dart that imports:
  • package:knt_ad_monetized/src/model/admob_config.dart that imports:
  • package:google_mobile_ads/google_mobile_ads.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:knt_ad_monetized/knt_ad_monetized.dart that imports:
  • package:knt_ad_monetized/src/widget/widgets.dart that imports:
  • package:knt_ad_monetized/src/widget/knt_native_ad.dart that imports:
  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • package:knt_ad_monetized/knt_ad_monetized.dart that imports:
  • package:knt_ad_monetized/src/widget/widgets.dart that imports:
  • package:knt_ad_monetized/src/widget/knt_interstitial_ad.dart that imports:
  • package:knt_ad_monetized/src/bloc/ad_without_view_bloc.dart that imports:
  • package:knt_ad_monetized/src/service/admob_service.dart that imports:
  • package:knt_ad_monetized/src/model/admob_config.dart that imports:
  • package:google_mobile_ads/google_mobile_ads.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `iOS`.

Because:

  • package:knt_ad_monetized/knt_ad_monetized.dart that imports:
  • package:knt_ad_monetized/src/widget/widgets.dart that imports:
  • package:knt_ad_monetized/src/widget/knt_native_ad.dart that imports:
  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Use 'TypeName _' instead of a type literal.

lib/src/bloc/ad_without_view_bloc.dart:157:12

    ╷
157 │       case PrepareAdWithoutViewEvent:
    │            ^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bloc/ad_without_view_bloc.dart

INFO: Use 'TypeName _' instead of a type literal.

lib/src/bloc/ad_without_view_bloc.dart:162:12

    ╷
162 │       case ShowAdWithoutViewEvent:
    │            ^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/bloc/ad_without_view_bloc.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
app_tracking_transparency ^2.0.4 2.0.4 2.0.4
flutter flutter 0.0.0 0.0.0
google_mobile_ads ^3.0.0 3.1.0 5.0.0
knt_base_monetized ^3.0.1 3.0.1 3.0.1
knt_bloc ^4.0.1 4.1.1 4.1.1
meta ^1.9.1 1.11.0 1.14.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
bloc - 8.1.4 8.1.4
bloc_concurrency - 0.2.5 0.2.5
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
connectivity_plus - 4.0.2 6.0.2
connectivity_plus_platform_interface - 1.2.4 2.0.0
dbus - 0.7.10 0.7.10
dio - 5.4.3+1 5.4.3+1
ffi - 2.1.2 2.1.2
flutter_bloc - 8.1.5 8.1.5
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
logger - 1.4.0 2.2.0
material_color_utilities - 0.8.0 0.11.1
nested - 1.0.0 1.0.0
nm - 0.5.0 0.5.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
scroll_to_index - 3.0.1 3.0.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
visibility_detector - 0.4.0+2 0.4.0+2
webview_flutter - 4.7.0 4.7.0
webview_flutter_android - 3.16.0 3.16.0
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.13.0 3.13.0
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on google_mobile_ads does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions google_mobile_ads to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.