kgress 0.0.12

Flutter Android iOS

RPG type stuff on an app

1
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Sep 30, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 107 out of 526 API elements (20.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:kgress/kgress.dart that imports:
  • package:kgress/game/world/game_world.dart that imports:
  • package:kgress/game/controller/element_controllers_repository_default.dart that imports:
  • package:kgress/game/tools/designer/tools_element_controller_repo.dart that imports:
  • package:kgress/game/tools/designer/game_designer_character.dart that imports:
  • package:kgress/game/imagesets/element_drawers.dart that imports:
  • package:flame/sprite.dart that imports:
  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:kgress/kgress.dart that imports:
  • package:kgress/game/world/game_world.dart that imports:
  • package:kgress/game/controller/element_controllers_repository_default.dart that imports:
  • package:kgress/game/tools/designer/tools_element_controller_repo.dart that imports:
  • package:kgress/game/tools/designer/game_designer_character.dart that imports:
  • package:kgress/game/imagesets/element_drawers.dart that imports:
  • package:flame/sprite.dart that imports:
  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform Linux

Because:

  • package:kgress/kgress.dart that imports:
  • package:kgress/game/world/game_world.dart that imports:
  • package:kgress/game/controller/element_controllers_repository_default.dart that imports:
  • package:kgress/game/tools/designer/tools_element_controller_repo.dart that imports:
  • package:kgress/game/tools/designer/game_designer_character.dart that imports:
  • package:kgress/game/imagesets/element_drawers.dart that imports:
  • package:flame/sprite.dart that imports:
  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that declares support for platforms: Android, iOS
Package does not support Flutter platform macOS

Because:

  • package:kgress/kgress.dart that imports:
  • package:kgress/game/world/game_world.dart that imports:
  • package:kgress/game/controller/element_controllers_repository_default.dart that imports:
  • package:kgress/game/tools/designer/tools_element_controller_repo.dart that imports:
  • package:kgress/game/tools/designer/game_designer_character.dart that imports:
  • package:kgress/game/imagesets/element_drawers.dart that imports:
  • package:flame/sprite.dart that imports:
  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:kgress/kgress.dart that imports:
  • package:kgress/game/world/game_world.dart that imports:
  • package:kgress/game/controller/element_controllers_repository_default.dart that imports:
  • package:kgress/game/tools/designer/tools_element_controller_repo.dart that imports:
  • package:kgress/game/tools/designer/game_designer_character.dart that imports:
  • package:kgress/game/imagesets/element_drawers.dart that imports:
  • package:flame/sprite.dart that imports:
  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:kgress/kgress.dart that imports:
  • package:kgress/game/world/game_world.dart that imports:
  • package:kgress/game/controller/element_controllers_repository_default.dart that imports:
  • package:kgress/game/tools/designer/tools_element_controller_repo.dart that imports:
  • package:kgress/game/tools/designer/game_designer_character.dart that imports:
  • package:kgress/game/imagesets/element_drawers.dart that imports:
  • package:flame/sprite.dart that imports:
  • package:flame/flame.dart that imports:
  • package:flame/flame_audio.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows
Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 95 issues. Showing the first 2:

WARNING: The parameter 'onPressed' is required.

lib/game/components/buttons/ControlArea.dart:55:24

   ╷
55 │                 child: FlatButton(
   │                        ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/game/components/buttons/ControlArea.dart

WARNING: The parameter 'onPressed' is required.

lib/game/components/buttons/ControlArea.dart:66:32

   ╷
66 │                         child: FlatButton(
   │                                ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/game/components/buttons/ControlArea.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
character_talk^0.0.50.0.50.0.5
cupertino_icons^0.1.20.1.31.0.0
flame^0.15.10.15.20.27.0
flutterflutter0.0.00.0.0
logging^0.11.3+20.11.40.11.4
optional^3.0.03.1.05.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.132.0.13
args-1.6.01.6.0
audioplayers-0.13.70.16.1
box2d_flame-0.4.60.4.6
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
flare_dart-2.3.42.3.4
flare_flutter-1.8.32.0.6
flutter_svg-0.14.40.19.0
intl-0.16.10.16.1
meta-1.1.81.2.3
ordered_set-1.1.52.0.0
path-1.7.01.7.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider-1.6.181.6.18
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+40.0.4+4
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
petitparser-3.0.43.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
sky_engine-0.0.990.0.99
synchronized-2.2.0+22.2.0+2
tiled-0.2.10.6.0
typed_data-1.2.01.2.0
uuid-2.2.22.2.2
vector_math-2.0.82.0.8
win32-1.7.31.7.3
xdg_directories-0.1.00.1.2
xml-3.7.04.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the latest published version `1.0.0`

pubspec.yaml:30:20

   ╷
30 │   cupertino_icons: ^0.1.2
   │                    ^^^^^^
   ╵
The constraint `^0.15.1` on flame does not support the latest published version `0.27.0`

pubspec.yaml:24:10

   ╷
24 │   flame: ^0.15.1
   │          ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs