kdbx 0.3.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 70

kdbx.dart #

KeepassX format implementation in pure dart.

Check out AuthPass Password Manager for an app which uses this library.

Resources #

Usage #

TODO

Features and bugs #

  • Supports kdbx v3 with native dart implementation
  • Supports kdbx v4 with combination with argon2 ffi

Argon2 support #

root directory contains shared libraris (libargon2*) which are built from https://github.com/authpass/argon2_ffi

OLD INFO: #

TODO #

0.3.0 #

  • Initial support for kdbx 4.x

0.2.1 #

  • Throw unsupported exception when trying to read kdbx 4.x files.

0.2.0 #

  • Fixed writing of packet index for payload.
  • Fixed big endian vs. little endian encoding.
  • Compatibility fixes with other kdbx apps.

0.1.0 #

  • Support for reading and writing kdbx 2.x files (with a master password)

0.0.1 #

  • Initial version, created by Stagehand

example/kdbx_example.dart

import 'package:kdbx/kdbx.dart';

void main() {
  KdbxFormat().read(null, null);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  kdbx: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:kdbx/kdbx.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
49
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Jul 7, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:kdbx/kdbx.dartpackage:kdbx/src/kdbx_object.dartpackage:kdbx/src/kdbx_group.dartpackage:kdbx/src/kdbx_entry.dartpackage:kdbx/src/kdbx_format.dartpackage:kdbx/src/kdbx_header.dartpackage:kdbx/src/kdbx_var_dictionary.dartpackage:kdbx/src/internal/byte_utils.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:kdbx/kdbx.dartpackage:kdbx/src/kdbx_object.dartpackage:kdbx/src/kdbx_group.dartpackage:kdbx/src/kdbx_entry.dartpackage:kdbx/src/kdbx_format.dartpackage:kdbx/src/kdbx_header.dartpackage:kdbx/src/kdbx_var_dictionary.dartpackage:kdbx/src/internal/byte_utils.dartdart:io

Health suggestions

Fix lib/src/kdbx_format.dart. (-1.99 points)

Analysis of lib/src/kdbx_format.dart reported 4 hints:

line 3 col 8: Unused import: 'dart:ffi'.

line 273 col 13: This function has a return type of 'Uint8List', but doesn't end with a return statement.

line 407 col 11: The value of the local variable 'expectedHmac' isn't used.

line 432 col 15: The value of the local variable 'blockHash' isn't used.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (cryptography, xml).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
args >1.5.0 <2.0.0 1.6.0
clock >=1.0.0 <2.0.0 1.0.1
collection >=1.14.0 <2.0.0 1.14.13
convert >=2.0.0 <3.0.0 2.1.1
crypto >=2.0.0 <3.0.0 2.1.5
cryptography ^0.1.2 0.1.2 1.4.1
ffi_helper ^1.4.0 1.4.0
logging >=0.11.3+2 <1.0.0 0.11.4
logging_appenders >=0.1.0 <1.0.0 0.4.2+3
meta >=1.0.0 <2.0.0 1.2.1
pointycastle >=1.0.1 <2.0.0 1.0.2
prompts >=1.3.0 <2.0.0 1.3.1
uuid >=2.0.0 <3.0.0 2.2.0
xml >=3.7.0 <4.0.0 3.7.0 4.2.0
Transitive dependencies
async 2.4.2
charcode 1.1.3
dio 3.0.9
http_parser 3.1.4
intl 0.16.1
io 0.3.4
path 1.7.0
petitparser 3.0.4
rxdart 0.24.1
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
Dev dependencies
ffi ^0.1.3 0.1.3
pedantic >=1.7.0 <2.0.0
test >=1.6.0 <2.0.0