juicer 0.10.0+4
juicer: ^0.10.0+4 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

Lightweight JSON serialization library for plain, mutable classes

4
likes
100 / 110
pub points
43 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 45 API elements (46.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.32.4 <1.0.00.41.21.1.0
build>=1.0.0 <2.0.01.6.21.6.3
source_gen>=0.9.0 <0.10.00.9.10+30.9.10+3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.017.0.0
args-1.6.02.0.0
async-2.4.22.5.0
charcode-1.1.31.2.0
cli_util-0.2.00.3.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
dart_style-1.3.121.3.14
file-5.2.16.1.0
glob-1.2.02.0.0
intl-0.16.10.17.0
js-0.6.20.6.3
logging-0.11.41.0.0
meta-1.2.41.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.7.01.8.0
pub_semver-1.4.42.0.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.32.4 <1.0.0` on analyzer does not support the latest published version `1.1.0`

pubspec.yaml:10:13

   ╷
10 │   analyzer: ">=0.32.4 <1.0.0"
   │             ^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

4
likes
100
pub points
43%
popularity

Lightweight JSON serialization library for plain, mutable classes

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

psiroki@skawa.hu

License

MIT (LICENSE)

Dependencies

analyzer, build, source_gen

More

Packages that depend on juicer