json_intl 2.0.0
json_intl: ^2.0.0 copied to clipboard

Flutter Internationalization library based on Json files and mustache replacement strings.

4
likes
130 / 130
pub points
56 %
popularity

We analyzed this package on Jul 31, 2021, and awarded it 130 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 39 out of 56 API elements (69.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.2.02.2.0
dart_style>=1.2.9 <3.0.02.0.32.0.3
flutterflutter0.0.00.0.0
intl^0.17.00.17.00.17.0
meta^1.3.01.3.01.7.0
path^1.8.01.8.01.8.0
simple_mustache^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.023.0.0
analyzer-1.7.12.0.0
async-2.8.12.8.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
cli_util-0.3.30.3.3
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
glob-2.0.12.0.1
package_config-2.0.02.0.0
pub_semver-2.0.02.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

4
likes
130
pub points
56%
popularity

Publisher

nfet.net

Flutter Internationalization library based on Json files and mustache replacement strings.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

args, dart_style, flutter, intl, meta, path, simple_mustache

More

Packages that depend on json_intl