jaguar_auth 2.4.4

Dart native
Flutter Android iOS

Authentication interceptors and helper functions for Jaguar

0
likes
70 / 110
pub points
53 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 70 API elements (44.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:jaguar_auth/jaguar_auth.dart that imports:
  • package:jaguar_auth/authorizer/authorizer.dart that imports:
  • package:jaguar_auth/exception/exception.dart that imports:
  • package:jaguar/jaguar.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 28 issues. Showing the first 2:

INFO: Unused import: 'dart:io'.

lib/authenticators/authenticators.dart:13:8

   ╷
13 │ import 'dart:io';
   │        ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/authenticators/authenticators.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/authenticators/basic_auth.dart:34:30

   ╷
34 │       this.authorizationIdKey: 'id',
   │                              ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/authenticators/basic_auth.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypto^2.0.32.1.52.1.5
jaguar^2.4.22.4.442.4.44
jaguar_common^2.1.42.1.42.1.4
Transitive dependencies
PackageConstraintCompatibleLatest
auth_header-2.1.42.1.4
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
http_server-0.9.8+30.9.8+3
jaguar_serializer-2.2.122.2.12
logging-0.11.40.11.4
meta-1.2.31.2.3
mime-0.9.70.9.7
path-1.7.01.7.0
path_tree-2.2.42.2.4
stack_trace-1.9.51.9.5
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
53%
popularity

Authentication interceptors and helper functions for Jaguar

Homepage

Documentation

API reference

Uploaders

segaud.kevin@gmail.com
tejainece@gmail.com

License

BSD (LICENSE)

Dependencies

crypto, jaguar, jaguar_common

More

Packages that depend on jaguar_auth