isar 3.1.0+1 copy "isar: ^3.1.0+1" to clipboard
isar: ^3.1.0+1 copied to clipboard

Extremely fast, easy to use, and fully async NoSQL database for Flutter.

1925
likes
120/ 140
pub points
99%
popularity

We analyzed this package 4 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

380 out of 381 API elements (99.7 %) have documentation comments.

Some symbols that are missing documentation: isar.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 33 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/annotations/backlink.dart:1:1

  ╷
1 │ part of isar;
  │ ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/annotations/backlink.dart

INFO: The part-of directive uses a library name.

lib/src/annotations/collection.dart:1:1

  ╷
1 │ part of isar;
  │ ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/annotations/collection.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi >=2.0.0 <3.0.0 2.1.2 2.1.2
js ^0.6.4 0.6.7 0.7.1
meta ^1.7.0 1.12.0 1.12.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.4` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

1925
likes
120
pub points
99%
popularity

Publisher

verified publisherisar.dev

Extremely fast, easy to use, and fully async NoSQL database for Flutter.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Funding

Consider supporting this project:

github.com

License

Apache-2.0 (LICENSE)

Dependencies

ffi, js, meta

More

Packages that depend on isar