irs_network_handler 0.0.1 copy "irs_network_handler: ^0.0.1" to clipboard
irs_network_handler: ^0.0.1 copied to clipboard

A pretty dio network handler

0
likes
40/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 40 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://techjr.in/flutter/packages/ was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 78 API elements (1.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: irs_network_handler, url, xhttp, xhttp.List2StringEx, xhttp.List2StringEx.listToStructureString.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: '/url.dart'.

lib/xhttp.dart:7:8

  ╷
7 │ import '/url.dart';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/xhttp.dart

ERROR: Undefined name 'Urls'.

lib/xhttp.dart:65:12

   ╷
65 │     return Urls.BASE_URL;
   │            ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/xhttp.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.4 4.0.6 5.4.3+1
flutter flutter 0.0.0 0.0.0
flutter_easyloading ^3.0.3 3.0.5 3.0.5
get ^4.6.1 4.6.6 4.6.6
logger ^1.1.0 1.4.0 2.2.0
pretty_dio_logger ^1.1.1 1.2.0-beta-1 1.3.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_spinkit - 5.2.1 5.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.4` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^1.1.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.