ip_geolocation 0.0.2
ip_geolocation: ^0.0.2 copied to clipboard

A dart package to flutter or dart projects to get your geolocation data from your IP, updated from Darwin Morocho's contribution.

1
likes
90/ 130
pub points
46%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 14 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/api.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/models/geolocation_data.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.13.30.13.40.13.4
meta^1.1.81.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-4.0.04.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

1
likes
90
pub points
46%
popularity

A dart package to flutter or dart projects to get your geolocation data from your IP, updated from Darwin Morocho's contribution.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, meta

More

Packages that depend on ip_geolocation