intl4x 0.8.1 copy "intl4x: ^0.8.1" to clipboard
intl4x: ^0.8.1 copied to clipboard

Platformweb

A lightweight modular library for internationalization (i18n) functionality.

4
likes
110/ 140
pub points
37%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

66 out of 299 API elements (22.1 %) have documentation comments.

Some symbols that are missing documentation: collation, collation.CaseFirst.jsName, collation.Collation, collation.Collation.Collation, collation.CollationOptions.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:intl4x/intl4x.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:intl4x/intl4x.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:intl4x/intl4x.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:intl4x/intl4x.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:intl4x/intl4x.dart that declares support for platforms: Web.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 168 issues. Showing the first 2:

WARNING: This API is available since SDK 3.3.0, but constraints '>=3.0.0 <4.0.0' don't guarantee it.

lib/src/bindings/Bcp47ToIanaMapper.g.dart:20:60

   ╷
20 │   static final _finalizer = ffi.NativeFinalizer(ffi.Native.addressOf(_ICU4XBcp47ToIanaMapper_destroy));
   │                                                            ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/bindings/Bcp47ToIanaMapper.g.dart

WARNING: This API is available since SDK 3.3.0, but constraints '>=3.0.0 <4.0.0' don't guarantee it.

lib/src/bindings/Bidi.g.dart:20:60

   ╷
20 │   static final _finalizer = ffi.NativeFinalizer(ffi.Native.addressOf(_ICU4XBidi_destroy));
   │                                                            ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/bindings/Bidi.g.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.1.0 2.1.2 2.1.2
js ^0.6.5 0.6.7 0.7.1
Transitive dependencies
Package Constraint Compatible Latest
meta - 1.12.0 1.12.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.5` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.4.0-131.0.dev.

Check the analysis log for details.

4
likes
110
pub points
37%
popularity

Publisher

verified publisherlabs.dart.dev

A lightweight modular library for internationalization (i18n) functionality.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ffi, js

More

Packages that depend on intl4x