intercom_plugin 0.1.6 icon indicating copy to clipboard operation
intercom_plugin: ^0.1.6 copied to clipboard

A plugin that translates the Intercom SDK into a plugin for Flutter

4
likes
100/ 140
pub points
10%
popularity

We analyzed this package 13 hours ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 20 API elements (75.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:intercom_plugin/intercom_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:intercom_plugin/intercom_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:intercom_plugin/intercom_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:intercom_plugin/intercom_plugin.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/intercom_plugin.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
intl^0.16.10.16.10.18.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

4
likes
100
pub points
10%
popularity

Publisher

verified publisher iconlucaseduardo.dev

A plugin that translates the Intercom SDK into a plugin for Flutter

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on intercom_plugin