interact 1.1.0
interact: ^1.1.0 copied to clipboard

Dart native
Flutter Android iOS

A collection of customizable interactive command-line components.

3
likes
90 / 110
pub points
42 %
popularity

We analyzed this package on Feb 24, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 121 out of 154 API elements (78.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:interact/interact.dart that imports:
  • package:interact/src/spinner.dart that imports:
  • package:interact/src/framework/framework.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib-win.dart that imports:
  • package:dart_console/src/ffi/termlib.dart that imports:
  • package:dart_console/src/ffi/unix/termlib-unix.dart that imports:
  • package:dart_console/src/ffi/unix/termios.dart that imports:
  • dart:ffi
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dart_console^0.6.20.6.21.0.0
meta^1.2.41.2.41.3.0
tint^1.0.01.0.11.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
ffi-0.1.31.0.0
win32-1.7.4+12.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.2` on dart_console does not support the latest published version `1.0.0`

pubspec.yaml:10:17

   ╷
10 │   dart_console: ^0.6.2
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

3
likes
90
pub points
42%
popularity

Publisher

frenco.dev

A collection of customizable interactive command-line components.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dart_console, meta, tint

More

Packages that depend on interact