inquiry 0.0.6 copy "inquiry: ^0.0.6" to clipboard
inquiry: ^0.0.6 copied to clipboard

The Inquiry package for Flutter simplifies creating custom questionnaires with trackable user data. Makes easily store the collected data locally or remotely.

9
likes
130/ 140
pub points
42%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

76 out of 98 API elements (77.6 %) have documentation comments.

Some symbols that are missing documentation: inquiry, inquiry.Inquiry, inquiry.Inquiry.Inquiry, inquiry.Inquiry.getPercentString, inquiry.InquiryOption.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:inquiry/inquiry.dart that imports:
  • package:inquiry/src/inquiry.dart that imports:
  • package:stacked/stacked.dart that imports:
  • package:stacked/src/code_generation/router_annotation/router_utils.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/inquiry.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/inquiry_view_model.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
percent_indicator ^4.2.3 4.2.3 4.2.3
stacked ^3.4.2 3.4.2 3.4.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
get_it - 7.7.0 7.7.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
stacked_shared - 1.4.0 1.4.0
typed_data - 1.3.2 1.3.2
universal_io - 2.2.2 2.2.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

9
likes
130
pub points
42%
popularity

Publisher

verified publisherch4rl3b.de

The Inquiry package for Flutter simplifies creating custom questionnaires with trackable user data. Makes easily store the collected data locally or remotely.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, percent_indicator, stacked

More

Packages that depend on inquiry