input_sheet 0.2.1
input_sheet: ^0.2.1 copied to clipboard

A flutter package to help apps with extensive forms, implementing inputs as BottomSheet to make it enjoyable.

42
likes
80/ 130
pub points
67%
popularity

We analyzed this package 42 hours ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 242 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:input_sheet/input_sheet.dart that imports:
  • package:input_sheet/sheet.dart that imports:
  • package:keyboard_utils/widgets.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
after_layout^1.0.7+21.1.01.1.0
cached_network_image^2.2.0+12.5.13.2.0
camera^0.5.8+10.5.8+170.9.4+5
flutterflutter0.0.00.0.0
flutter_cupertino_date_picker^1.0.241.0.26+21.0.26+2
flutter_feather_icons^1.0.31.0.32.0.0+1
flutter_keyboard_size^0.1.2+20.1.2+21.0.0+4
flutter_masked_text^0.8.00.8.00.8.0
flutter_mobx^1.1.01.1.0+22.0.2
intl^0.16.10.16.10.17.0
keyboard_utils^1.2.11.3.31.3.3
mobx^1.2.11.2.1+42.0.5
path_provider^1.6.81.6.282.0.7
permission_handler^5.0.1+15.1.0+28.3.0
quiver^2.0.52.1.53.0.1+1
uuid^2.0.42.2.23.0.5
video_compress^2.0.02.1.13.1.0
video_player^0.10.110.10.12+52.2.7
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
args-1.6.02.3.0
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.5.00.6.0
flutter_cache_manager-2.1.23.3.0
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image-2.1.193.1.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
octo_image-0.3.01.0.1
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
pedantic-1.11.11.11.1
permission_handler_platform_interface-2.0.23.7.0
petitparser-3.1.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
provider-4.3.36.0.1
rxdart-0.25.00.27.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
video_player_platform_interface-2.2.04.2.0
video_player_web-0.1.4+12.0.4
win32-2.3.12.3.1
xdg_directories-0.1.20.2.0
xml-4.5.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 13 issues. Showing the first 2:

The constraint `^2.2.0+1` on cached_network_image does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions cached_network_image to update the constraint.

The constraint `^0.5.8+1` on camera does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions camera to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.