ingdao 0.0.37
ingdao: ^0.0.37 copied to clipboard

Data Management Framework

0
likes
45/ 130
pub points
49%
popularity

We analyzed this package on Dec 3, 2021, and awarded it 45 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis http://dev.g-i.com.my/istudio/docs/flutter/idao/flutter-sdk-idao/ was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 image link is insecure.

README.md:19:2

   ╷
19 │  <img src="http://dev.g-i.com.my/istudio/img/idaoarch.jpg"/>
   │  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 724 API elements (1.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:ingdao/ingdao.dart that imports:
  • package:ingdao/dataflow/control/dfresponse.dart that imports:
  • package:ingdao/dataflow/repository/dfdbrepository.dart that imports:
  • package:ing_app_security/ing_app_security.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 40 issues. Showing the first 2:

lib/dataflow/control/dfconverter.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/dataflow/control/dfquery.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
aes_crypt^0.1.10.1.10.1.1
connectivity^3.0.33.0.63.0.6
cryptography^2.0.12.0.52.0.5
data_connection_checker^0.3.40.3.40.3.4
flutterflutter0.0.00.0.0
flutter_secure_storage^3.3.53.3.55.0.2
http^0.13.00.13.40.13.4
ing_app_security^0.0.70.0.70.0.7
intl^0.17.00.17.00.17.0
meta^1.2.41.7.01.7.0
nui_web^0.0.250.0.290.0.29
object_mapper^1.0.0+21.2.11.2.1
package_info^0.4.3+20.4.3+42.0.2
path^1.7.01.8.01.8.0
shared_preferences^2.0.52.0.92.0.9
sqflite2.0.0+32.0.0+32.0.0+4
ssl_pinning_plugin^1.5.11.5.12.0.0
uuid^3.0.03.0.53.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
animator-3.1.03.1.0
args-1.6.02.3.0
asn1lib-0.8.11.0.3
async-2.8.22.8.2
cached_network_image-3.2.03.2.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
carousel_slider-4.0.04.0.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
crypto-3.0.13.0.1
csslib-0.17.10.17.1
date_util-0.1.40.1.4
device_info-2.0.32.0.3
device_info_platform_interface-2.0.12.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
fixnum-1.0.01.0.0
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_markdown-0.2.00.6.8
flutter_staggered_grid_view-0.3.40.4.1
flutter_svg-0.22.01.0.0
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
html2md-1.2.51.2.5
http_parser-4.0.04.0.0
ios_utsname_ext-1.1.02.1.0
js-0.6.30.6.3
line_awesome_flutter-2.0.02.0.0
markdown-2.1.84.0.1
nui_animation-0.0.20.0.2
nui_core-0.0.2350.1.1
nui_database-0.0.110.0.11
nui_error_handler-0.0.110.0.11
nui_toolbox-0.0.470.0.47
octo_image-1.0.11.0.1
path_drawing-0.5.1+11.0.0
path_parsing-0.2.11.0.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
permission_handler-8.3.08.3.0
permission_handler_platform_interface-3.7.03.7.0
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
pointycastle-2.0.13.4.0
process-4.2.44.2.4
pull_to_refresh-2.0.02.0.0
rxdart-0.27.30.27.3
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
shimmer-1.1.22.0.0
simple_gesture_detector-0.2.00.2.0
skeleton_loader-1.0.2+32.0.0+4
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-2.0.1+12.0.1+1
states_rebuilder-4.4.05.0.0
steel_crypt-2.3.1+63.0.0+1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
table_calendar-3.0.33.0.3
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
url_launcher-6.0.176.0.17
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
vector_math-2.1.02.1.1
visibility_detector-0.2.20.2.2
win32-2.3.12.3.1
workmanager-0.2.40.4.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^3.3.5` on flutter_secure_storage does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

The constraint `^0.4.3+2` on package_info does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions package_info to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.