immutable_model 0.9.4 icon indicating copy to clipboard operation
immutable_model: ^0.9.4 copied to clipboard

Define valid, hierarchical immutable state models with an expressive API for updating state data and transitioning between states.

2
likes
100/ 140
pub points
0%
popularity

We analyzed this package 38 hours ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 337 out of 398 API elements (84.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'errors.dart' is unnecessary because all of the used elements are also provided by the import of '../immutable_model.dart'.

lib/src/model_selector.dart:3:8

  ╷
3 │ import 'errors.dart';
  │        ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/model_selector.dart

INFO: 'List.List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/model_types/lists/model_value_list.dart:48:7

   ╷
48 │       List<M>(numberOfDefault)..fillRange(0, numberOfDefault, defaultModel),
   │       ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/model_types/lists/model_value_list.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection^4.3.24.3.25.1.1
collection^1.14.131.17.11.17.1
crypto^2.1.52.1.53.0.2
equatable^1.2.51.2.62.0.5
logging^0.11.40.11.41.1.1
meta^1.1.81.9.01.9.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
convert-2.1.13.1.1
matcher-0.12.140.12.14
path-1.8.31.8.3
quiver-2.1.53.2.1
stack_trace-1.11.01.11.0
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^4.3.2` on built_collection does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions built_collection to update the constraint.

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Dart 2.19.0.

2
likes
100
pub points
0%
popularity

Publisher

unverified uploader

Define valid, hierarchical immutable state models with an expressive API for updating state data and transitioning between states.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

built_collection, collection, crypto, equatable, logging, meta

More

Packages that depend on immutable_model