image_picker_platform_interface 2.6.1 icon indicating copy to clipboard operation
image_picker_platform_interface: ^2.6.1 copied to clipboard

A common platform interface for the image_picker plugin.

3
likes
110/ 130
pub points
98%
popularity

We analyzed this package 24 hours ago, and awarded it 110 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 64 out of 69 API elements (92.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cross_file^0.3.1+10.3.3+10.3.3+1
flutterflutter0.0.00.0.0
http^0.13.00.13.50.13.5
plugin_platform_interface^2.1.02.1.22.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
collection-1.16.01.16.0
http_parser-4.0.14.0.1
js-0.6.40.6.4
material_color_utilities-0.1.40.2.0
meta-1.7.01.8.0
path-1.8.21.8.2
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.14, Flutter 3.0.4, Dart 2.17.5.