image_form_field_x 0.0.8
image_form_field_x: ^0.0.8 copied to clipboard

Flutter Android iOS

Upload images in Flutter forms

0
likes
80 / 110
pub points
23 %
popularity

We analyzed this package on Jan 25, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 15 API elements (73.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:image_form_field_x/image_form_field_x.dart that imports:
  • package:image_form_field_x/src/field.dart that imports:
  • package:image_form_field_x/src/button.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: 'pickImage' is deprecated and shouldn't be used. Use imagePicker.getImage() method instead..

lib/src/button.dart:32:37

   ╷
32 │     final image = await ImagePicker.pickImage(source: source);
   │                                     ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/button.dart

INFO: 'List' is deprecated and shouldn't be used.

lib/src/controller.dart:10:66

   ╷
10 │   ImageFieldController.fromValue(List<T> value) : super(value ?? List<T>());
   │                                                                  ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/controller.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
image_picker^0.6.1+100.6.7+210.6.7+21
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
flutter_plugin_android_lifecycle-1.0.111.0.11
http-0.12.20.12.2
http_parser-3.1.43.1.4
image_picker_platform_interface-1.1.11.1.1
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
pedantic-1.9.21.9.2
plugin_platform_interface-1.0.31.0.3
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs