image_extensions 0.2.0 copy "image_extensions: ^0.2.0" to clipboard
image_extensions: ^0.2.0 copied to clipboard

A wrapper library for [image package](https://pub.dev/packages/image) with some extra functions.

2
likes
120/ 140
pub points
25%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

507 out of 2210 API elements (22.9 %) have documentation comments.

Some symbols that are missing documentation: image_extensions, image_extensions.BitUtility, image_extensions.BitUtility.BITSCALE_3_TO_8, image_extensions.BitUtility.BITSCALE_4_TO_8, image_extensions.BitUtility.BITSCALE_5_TO_8.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:image_extensions/image_extensions.dart that imports:
  • package:image_extensions/src/extensions.dart that imports:
  • package:image_extensions/src/functions.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/gradients.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.4 0.13.6 1.2.1
image ^3.1.1 3.3.0 4.1.7
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.7.4 3.7.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.1.1` on image does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

2
likes
120
pub points
25%
popularity

Publisher

verified publishervanxh.dev

A wrapper library for [image package](https://pub.dev/packages/image) with some extra functions.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

http, image

More

Packages that depend on image_extensions