image_cropper 5.0.1 copy "image_cropper: ^5.0.1" to clipboard
image_cropper: ^5.0.1 copied to clipboard

A Flutter plugin for Android, iOS and Web supports cropping images

2024
likes
125/ 140
pub points
99%
popularity

We analyzed this package 1 hour ago, and awarded it 125 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:13:665

   ╷
13 │ <p><a href="https://GitHub.com/TimOliver/TOCropViewController/watchers/"><img src="https://img.shields.io/github/watchers/TimOliver/TOCropViewController.svg?style=social&label=Watch&maxAge=2592000" alt="GitHub watchers" /></a>  <a href="https://GitHub.com/TimOliver/TOCropViewController/stargazers/"><img src="https://img.shields.io/github/stars/TimOliver/TOCropViewController.svg?style=social&label=Star&maxAge=2592000" alt="GitHub stars" /></a>  <a href="https://GitHub.com/TimOliver/TOCropViewController/network/"><img src="https://img.shields.io/github/forks/TimOliver/TOCropViewController.svg?style=social&label=Fork&maxAge=2592000" alt="GitHub forks" /></a> <a href="http://cocoadocs.org/docsets/TOCropViewController"><img src="https://img.shields.io/cocoapods/v/TOCropViewController.svg?style=flat" alt="Version" /></a> <a href="https://raw.githubusercontent.com/TimOliver/TOCropViewController/master/LICENSE"><img src="https://img.shields.io/badge/license-MIT-blue.svg" alt="GitHub license" /></a></p>

[...]

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

70 out of 107 API elements (65.4 %) have documentation comments.

Some symbols that are missing documentation: image_cropper.AndroidUiSettings.toMap, image_cropper.CropAspectRatio, image_cropper.CropAspectRatio.CropAspectRatio, image_cropper.CropAspectRatio.ratioX, image_cropper.CropAspectRatio.ratioY.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:image_cropper/image_cropper.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:image_cropper/image_cropper.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:image_cropper/image_cropper.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:image_cropper/image_cropper.dart that imports:
  • package:image_cropper/src/cropper.dart that imports:
  • package:image_cropper_platform_interface/image_cropper_platform_interface.dart that imports:
  • package:image_cropper_platform_interface/src/platform_interface/image_cropper_platform.dart that imports:
  • package:image_cropper_platform_interface/src/method_channel/method_channel_image_cropper.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Dangling library doc comment.

lib/image_cropper.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/image_cropper.dart

lib/src/cropper.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
image_cropper_for_web ^3.0.0 3.0.0 3.0.0
image_cropper_platform_interface ^5.0.0 5.0.0 5.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2024
likes
125
pub points
99%
popularity

Publisher

verified publisherhunghd.dev

A Flutter plugin for Android, iOS and Web supports cropping images

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, image_cropper_for_web, image_cropper_platform_interface

More

Packages that depend on image_cropper