image_compare 1.1.2 icon indicating copy to clipboard operation
image_compare: ^1.1.2 copied to clipboard

Dart package for image comparison. Compare images for difference using a variety of algorithms.

36
likes
120/ 140
pub points
85%
popularity

We analyzed this package 6 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 51 out of 73 API elements (69.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: An uninitialized field should have an explicit type annotation.

lib/src/algorithms.dart:7:7

  ╷
7 │   var _pixelListPair;
  │       ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/algorithms.dart

INFO: An uninitialized field should have an explicit type annotation.

lib/src/algorithms.dart:100:7

    ╷
100 │   var ignoreAlpha;
    │       ^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/algorithms.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
image^3.0.03.3.04.0.13
universal_io^2.0.02.0.42.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.63.3.6
collection-1.17.11.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
js-0.6.70.6.7
meta-1.9.01.9.0
path-1.8.31.8.3
petitparser-5.1.05.1.0
pointycastle-3.6.23.6.2
typed_data-1.3.11.3.1
xml-6.2.26.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on image does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.0.

36
likes
120
pub points
85%
popularity

Publisher

unverified uploader

Dart package for image comparison. Compare images for difference using a variety of algorithms.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

image, universal_io

More

Packages that depend on image_compare