iirjdart 0.0.1
iirjdart: ^0.0.1 copied to clipboard

An IIR filter library written in Dart. Highpass, lowpass, bandpass and bandstop as Butterworth, Bessel and Chebyshev Type I/II.

6
likes
90/ 130
pub points
71%
popularity

We analyzed this package on Nov 25, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 52 API elements (32.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

lib/butterworth.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/chebyshev_1.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
complex^0.5.00.5.00.7.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0` on complex does not support the stable version `0.6.0`.

Try running dart pub upgrade --major-versions complex to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

6
likes
90
pub points
71%
popularity

An IIR filter library written in Dart. Highpass, lowpass, bandpass and bandstop as Butterworth, Bessel and Chebyshev Type I/II.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

complex, flutter

More

Packages that depend on iirjdart